WordPress 5.6 Update December 2020, WordPress 5.6 update, WordPress 5.5 Update

WordPress 5.6 Update December 2020

WordPress 5.6 Update December 2020 will make the jQuery Helper plugin useless which means that some websites may break again. Here, we are going to discuss WordPress 5.6 Update December 2020.

WordPress 5.5 update was released in August 2020 and after the update, millions of websites across the Internet were broken. Now, get ready for the new WordPress 5.6 update on December 2020 has the potential to do the same thing as WordPress 5.5 update did.

One of the WordPress plugin developers behind the jQuery Migrate Plugin gives an update in a support thread that the plugin would become useless once the new update of WordPress 5.6 is rolled out. Anyone who is depending on it in December they will experience the new WordPress 5.6 update on their websites.

WordPress 5.6 Update December 2020

Why WordPress 5.6 Break some websites

WordPress is planning three phases of Modernization of the use of jQuery. jQuery is a set of scripts that give different functionalities to websites like animations, provide interactive elements to the website pages, helpful in creating Plugins and themes because jQuery handles common features of websites and manipulate the CSS with it.

WordPress 5.6 Update December 2020

Previous or older jQuery versions are still being used in many themes and plugins. Older jQuery libraries contain XSS (Cross-site Scripting) and DoS (Denial of Service) vulnerabilities, which can be dangerous for those websites that are using the older version of jquery.

WordPress 5.5 update was the first step of modernization by WordPress by forcing the whole WordPress ecosystem to update their code with the latest and secure version of jQuery.

The first step of the WordPress update journey was to remove or end the jQuery Migrate 1.x library.

jQuery Migrate Library Enabler Plugin is a code that allows a website working with those plugins who are using old versions of jQuery. Because it makes a WordPress website backward compatible with themes and plugins in which an older version of jQuery is running or used.

When WordPress 5.5 version is released in August 2020, millions of websites stop working as they should. Some of the website owners were locked out of their websites and they couldn’t;t login into their WordPress website admin panel. And many other publishers saw their whole websites stop displaying.

WordPress 5.6 December 2020 update will roll out step 2 of modernizing the use of jQuery by updating the jQuery Migrate library to the latest and updated version 3.3.1.

The purpose of doing that, websites that are relying on the “Enable jQUery Migrate Helper” to keep their website from falling apart are going to suffer all over again after the new update of WordPress 5.6.

WordPress 5.6 Update December 2020

All the functionalities of all websites that are still relying on the Enable jQuery Migrate Helper Plugin to keep their website functioning, These websites will face the break-in their functionalities.

On the support forum of WordPress Enable jQuery Migrate helper, someone asked the following Question.

Question: “When the WordPress 5.6 version update arrives, will Enable jQuery Migrate Helper plugin still work?”

The WordPress plugin developer answered:

Answer: “So the short of it is that no, it will not help once WordPress 5.6 version comes around, as the jQuery library in WordPress is planned to be upgraded, and that would leave this helper useless.”

Will WordPress 5.6 Update December 2020 Break your Website?

If you are currently using the Enable jQuery Migrate Helper plugin, when you log in to your WordPress admin panel you will get error messages, then yes you may experience unexpected behavior of your website when your WordPress is updated to WordPress 5.6 version.

On another side, if the Enable jQuery Migrate Helper not reporting any kind of errors that means your themes and plugins have updated their jQuery libraries and your website should work well.

Conclusion

Now, as we see soon WordPress 5.5 will update to WordPress 5.6 in December 2020 and this update occurs to modernize the jQuery of WordPress themes and plugins otherwise many websites will face issues, like the website will stop working or down due to the new WordPress 5.6 Update. It’s time to update our Themes and Plugins jQuery according to the update of WordPress 5.6 by implementing a new jQuery script code in our Plugins and Themes to avoid this issue that can occur in our websites after the release of WordPress 5.6 December Update.

0Shares

Leave a Reply

Your email address will not be published. Required fields are marked *

This site uses Akismet to reduce spam. Learn how your comment data is processed.